A small, lightweight and extensible DynDNS server written with Ruby and Rack.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

44 lines
1.4 KiB

  1. # frozen_string_literal: true
  2. require_relative 'lib/dyndnsd/version'
  3. Gem::Specification.new do |s|
  4. s.name = 'dyndnsd'
  5. s.version = Dyndnsd::VERSION
  6. s.summary = 'dyndnsd.rb'
  7. s.description = 'A small, lightweight and extensible DynDNS server written with Ruby and Rack.'
  8. s.author = 'Christian Nicolai'
  9. s.homepage = 'https://github.com/cmur2/dyndnsd'
  10. s.license = 'Apache-2.0'
  11. s.metadata = {
  12. 'bug_tracker_uri' => "#{s.homepage}/issues",
  13. 'changelog_uri' => "#{s.homepage}/blob/master/CHANGELOG.md",
  14. 'source_code_uri' => s.homepage
  15. }
  16. s.files = `git ls-files -z`.split("\x0").select do |f|
  17. f.match(%r{^(init.d|lib)/})
  18. end
  19. s.require_paths = ['lib']
  20. s.bindir = 'exe'
  21. s.executables = ['dyndnsd']
  22. s.extra_rdoc_files = Dir['README.md', 'CHANGELOG.md', 'LICENSE']
  23. s.required_ruby_version = '>= 2.3'
  24. s.add_runtime_dependency 'jaeger-client', '~> 0.10.0'
  25. s.add_runtime_dependency 'metriks'
  26. s.add_runtime_dependency 'opentracing', '~> 0.5.0'
  27. s.add_runtime_dependency 'rack', '~> 2.0'
  28. s.add_runtime_dependency 'rack-tracer', '~> 0.9.0'
  29. s.add_development_dependency 'bundler'
  30. s.add_development_dependency 'bundler-audit', '~> 0.7.0'
  31. s.add_development_dependency 'rack-test'
  32. s.add_development_dependency 'rake'
  33. s.add_development_dependency 'rspec'
  34. s.add_development_dependency 'rubocop', '~> 0.81.0'
  35. s.add_development_dependency 'solargraph'
  36. end