gem: drop support for Rubies < 2.7

pull/172/head
cn 5 months ago
parent 451ed20f5d
commit 4237d35fcc
  1. 2
      .github/workflows/ci.yml
  2. 2
      .rubocop.yml
  3. 6
      CHANGELOG.md
  4. 2
      dyndnsd.gemspec

@ -17,8 +17,6 @@ jobs:
strategy:
matrix:
ruby-version:
- '2.5'
- '2.6'
- '2.7'
- '3.0'
- '3.1'

@ -3,7 +3,7 @@ require:
- rubocop-rspec
AllCops:
TargetRubyVersion: '2.5'
TargetRubyVersion: '2.7'
NewCops: enable
Gemspec/RequireMFA:

@ -1,5 +1,11 @@
# Changelog
## 3.6.0
IMPROVEMENTS:
- Drop EOL Ruby 2.6 and lower support, now minimum version supported is Ruby 2.7
## 3.5.3 (May 5th, 2022)
OTHER:

@ -25,7 +25,7 @@ Gem::Specification.new do |s|
s.executables = ['dyndnsd']
s.extra_rdoc_files = Dir['README.md', 'CHANGELOG.md', 'LICENSE']
s.required_ruby_version = '>= 2.5'
s.required_ruby_version = '>= 2.7'
s.add_runtime_dependency 'async', '~> 1.30.0'
s.add_runtime_dependency 'async-dns', '~> 1.3.0'

Loading…
Cancel
Save