Bläddra i källkod

gem: bump minimum required Ruby version to Ruby 2.5

tags/v3.0.0
cn 4 månader sedan
committad av Christian Nicolai
förälder
incheckning
b2d9b7745f
5 ändrade filer med 13 tillägg och 10 borttagningar
  1. +2
    -1
      .rubocop.yml
  2. +0
    -2
      .travis.yml
  3. +6
    -0
      CHANGELOG.md
  4. +2
    -2
      dyndnsd.gemspec
  5. +3
    -5
      lib/dyndnsd/textfile_reporter.rb

+ 2
- 1
.rubocop.yml Visa fil

@ -1,5 +1,6 @@
AllCops:
TargetRubyVersion: '2.3'
TargetRubyVersion: '2.5'
NewCops: enable
Layout/EmptyLineAfterGuardClause:
Enabled: false

+ 0
- 2
.travis.yml Visa fil

@ -5,8 +5,6 @@ rvm:
- 2.7
- 2.6
- 2.5
- 2.4
- 2.3
script:
- bundle exec rake travis

+ 6
- 0
CHANGELOG.md Visa fil

@ -1,5 +1,11 @@
# Changelog
## 3.0.0
IMPROVEMENTS:
- Drop EOL Ruby 2.4 and lower support, now minimum version supported is Ruby 2.5
## 2.3.1 (July 27, 2020)
IMPROVEMENTS:

+ 2
- 2
dyndnsd.gemspec Visa fil

@ -25,7 +25,7 @@ Gem::Specification.new do |s|
s.executables = ['dyndnsd']
s.extra_rdoc_files = Dir['README.md', 'CHANGELOG.md', 'LICENSE']
s.required_ruby_version = '>= 2.3'
s.required_ruby_version = '>= 2.5'
s.add_runtime_dependency 'async-dns', '~> 1.2.0'
s.add_runtime_dependency 'jaeger-client', '~> 0.10.0'
@ -39,6 +39,6 @@ Gem::Specification.new do |s|
s.add_development_dependency 'rack-test'
s.add_development_dependency 'rake'
s.add_development_dependency 'rspec'
s.add_development_dependency 'rubocop', '~> 0.81.0'
s.add_development_dependency 'rubocop', '~> 0.82.0'
s.add_development_dependency 'solargraph'
end

+ 3
- 5
lib/dyndnsd/textfile_reporter.rb Visa fil

@ -28,11 +28,9 @@ module Dyndnsd
sleep @interval
Thread.new do
begin
write
rescue StandardError => e
@on_error[e] rescue nil
end
write
rescue StandardError => e
@on_error[e] rescue nil
end
end
end

Laddar…
Avbryt
Spara